unknown error when installing PolyMon

Topics: User Forum
Jun 12, 2011 at 5:13 PM

Hi all,

I'm trying to install the latest release of PolyMon on my Windows Server 2008 R2 machine, and I get the following error: "error -2147467259: failed to create SQL Database: PolyMon, Error detail: unknown error".  I have my SQL Server 2008 R2 Express database set for mixed mode authentication, but I told the installer to use integrated authentication leaving that box checked.  Should I have unchecked it?  Is that what the error means?  I'm assuming it is, but if somebody could please let me know, I'd appreciate it very much.  Thanks. 

 

Chromebuster

Coordinator
Jun 22, 2011 at 8:04 PM

Did you ever find the answer Chromebuster?  Try uninstalling and then re-installing with it unchecked.  You could also temporarily set SQL to integrated security and see if that works and then switch it back.  Let us know. Thanks.

Jun 22, 2011 at 8:18 PM

 

I tried that.  I think I might have figured it out, though because I'm currently working on a million things at once here, I haven't gotten around to actually trying it.  Tell me this if you don't mind.  When supplying the installer with the location of the database server, if it happens to be the local host, which on mine it is, then do you have to type localhost\SQLExpress if using the Express edition of SQL Server 2008?  I'm using SQL Server 2008 rather than the 2005 version because others have gotten that to work.  By the way, will the next version of PolyMon have native SQL Server 2008 support?  Thanks. 

Coordinator
Jun 22, 2011 at 8:23 PM

Yes, you would have to enter either type the machine name or localhost.

I'm not sure about PolyMon 2.  We are all working in our spare time to do this project and I personally haven't touched it for almost a year.  I have a 1yr old running around now, so my free time got eaten up quickly.  Although, I do want to get back into it sometime this year.  We will certainly let you know when we do.  Thanks for all of the support. It really helps.

Jun 22, 2011 at 9:24 PM

Oh oops. Thanks. I’ll be sure to try that again with the SQLExpress portion of the connection string specified. I for some reason thought that it was only for web.config files you had to do that.

From: jonebersole [email removed]
Sent: Wednesday, June 22, 2011 4:23 PM
To: Katherine Moss
Subject: Re: unknown error when installing PolyMon [polymon:261110]

From: jonebersole

Yes, you would have to enter either type the machine name or localhost.

I'm not sure about PolyMon 2. We are all working in our spare time to do this project and I personally haven't touched it for almost a year. I have a 1yr old running around now, so my free time got eaten up quickly. Although, I do want to get back into it sometime this year. We will certainly let you know when we do. Thanks for all of the support. It really helps.

Coordinator
Jun 22, 2011 at 9:36 PM

It's actually part of 'the way SQL works'.  It has to do with SQL Instances.  Each instance has it's own unique name, so that each application can install their own SQL instance and keep them separate from other instances.  This way, when some other application does its uninstall, it will only uninstall their instance, not yours.  By default, when installing SQL Express, it creates its' own instance on your system as <machine_name>/SQLExpress.  Web.config files follow the same rules as does your computer and other software, so whatever you have to use in the web.config is almost what you should use elsewhere with some exceptions.

Jun 22, 2011 at 9:55 PM

That’s a good thing I never knew, but considering I’m trying to jump on the .net bandwagon, I’m glad somebody told me so that I don’t make those mistakes in the future on my own endeavors in creating applications.

From: jonebersole [email removed]
Sent: Wednesday, June 22, 2011 5:36 PM
To: Katherine Moss
Subject: Re: unknown error when installing PolyMon [polymon:261110]

From: jonebersole

It's actually part of 'the way SQL works'. It has to do with SQL Instances. Each instance has it's own unique name, so that each application can install their own SQL instance and keep them separate from other instances. This way, when some other application does its uninstall, it will only uninstall their instance, not yours. By default, when installing SQL Express, it creates its' own instance on your system as <machine_name>/SQLExpress. Web.config files follow the same rules as does your computer and other software, so whatever you have to use in the web.config is almost what you should use elsewhere with some exceptions.

Jul 7, 2011 at 10:34 PM

Darn.  I still can't get the error to quit showing up no matter which way I put in the connection string, it's always the same error.  I don't know if I should switch the authentication on SQL Server itself, because the problem with that is that I have a web application running on the same (and my only server thank God), that needs it to use SQL Authentication.  What do you suggest I do from here?  Thanks. 

Jul 11, 2011 at 10:30 AM

Not sure what you have tried, but give it a shot with

.\sqlexpress

If the above does not work, try

(local)\sqlexpress
computername\sqlexpress 

 

This implies that your instance is named sqlexpress !

Jul 11, 2011 at 3:20 PM

I was using localhost\SQLExpress. I’ll try the latter options though, though I know that (local) implies that named pipes are the protocol being used.

From: gurbao [email removed]
Sent: Monday, July 11, 2011 6:30 AM
To: Katherine Moss
Subject: Re: unknown error when installing PolyMon [polymon:261110]

From: gurbao

Not sure what you have tried, but give it a shot with

.\sqlexpress

If the above does not work, try

(local)\sqlexpress
computername\sqlexpress

This implies that your instance is named sqlexpress !