for some help , thank you all

Topics: User Forum
Nov 18, 2010 at 6:28 PM

I'm new to PolyMon , i have a problem in using polymon which troublued me  for some days.

when i test a cpumonitor or wmimonitor,  I get a "access denied" error. i know it may occur when the host( where polymon service or manager run on) have not Permissions or authorization.  so first i create an Active Directory on a host  "SA"  (windows server 2003, create a domain named newdomain),then i put all hosts which need be  monitored in the newdomain. and  then  , i run polymon executive service and polymon manager in the “SA” host  with the administrator of the newdomain . But  i  still get an "access denied" error when i run cpumonitor on all other host ,  which make me crazy.......if i do something wrong? or the settings of the newdomain is wrong?   Thanks for answering! 

Coordinator
Nov 23, 2010 at 10:06 PM

When you run the monitors interactively in PolyMon Manager (e.g. manual execution using "Test"), then the monitor will try to access the resource you are monitoring using the credentials of the user your are logged in as (typical default).

When the monitors are being run using PolyMon Executive, which is a windows service, the monitors are being executed under the credentials you use for running the service.

So basically, you need to be sure that the credentials/user account you use has access rights to query the various servers. Try running these both under a domain admin account and make sure everything is working OK. That way you can make sure there is not another issue (e.g. firewall blocking). Then by all means create separate domain accounts with the properly restricted access rights and use those to run the service. If you want to be able to run the monitors within the Manager app, you may also have to set the Manager application to Run as Administrator (that has been my experience under Win7 64-bit) as well as making sure that your logged in using a domain account that has the correct access rights.

 

Fred.