2 errors that come and go

Topics: Developer Forum, User Forum
Dec 10, 2007 at 8:59 AM
Hi,

I have recently started using the Polymon on a dev server in my company.
Currently I have 2 monitors: one for checking free space on logical disk and another for validating sql server agent service is up.
Yesterday I got these two errors:
1. Cannot open Service Control Manager on computer 'localhost'. This operation might require other privileges. (SQL Server Agent availability Service Monitor)
2. Monitor Run Exception Object reference not set to an instance of an object. (Disk U Free Space Disk Monitor)
after stopping polymon service for a day (I just didn't have time to look up the problem) and restarting it today it seems that everything is back to normal.
Has anyone encountered these problems with polymon?
(I have Win Server 2003 R2 std, SQL Server 2005 Dev edition)
Thanks!

Jun 25, 2008 at 9:57 PM


odedb wrote:
Hi,

I have recently started using the Polymon on a dev server in my company.
Currently I have 2 monitors: one for checking free space on logical disk and another for validating sql server agent service is up.
Yesterday I got these two errors:
1. Cannot open Service Control Manager on computer 'localhost'. This operation might require other privileges. (SQL Server Agent availability Service Monitor)
2. Monitor Run Exception Object reference not set to an instance of an object. (Disk U Free Space Disk Monitor)
after stopping polymon service for a day (I just didn't have time to look up the problem) and restarting it today it seems that everything is back to normal.
Has anyone encountered these problems with polymon?
(I have Win Server 2003 R2 std, SQL Server 2005 Dev edition)
Thanks!



I receive a similar error monitoring a service on a remote computer, the exception being 'remote server name' in place of 'local' host.  I changed the Account for the Polymon Executive service to run under an account that has Administrative right on the remote server an the errors are gone.  I'm assuming that I probably have to use a Domain Admin account if I want to use this for several servers.
I don't know if this helps, but it resolved my problem and yes, I'm fairly new at this too.